Website TW-DB.info - English support

Pnevma

Well-Known Member
The ZZZ button on the top left doesn't fully work when you have forts and a single town, with no alliance.
It automatically sets you to sleep at home, and doesn't give you the option to sleep in one of your forts.

I understand this is unlikely to be fixed, but I had to try :D ...



PS: if it helps, I think it is related to this line:
Code:
var S=function(){if(w.Character.homeTown.alliance_id==0){return}Ajax.remoteCallMode("alliance","get_data",{alliance_id:w.Character.homeTown.alliance_id},function(e){if(e.error){return(new UserMessage(e.error)).show()}i=e.data.forts
 
Last edited:

Wondertje

Well-Known Member
Thanks for the report. Someone already told me about this and I will fix it and tell Petee to release it.
So, is there any chance you could be given the rights/option to actually release the work you're doing?
I'm in no way meaning any disrespect to Petee, people move in - it happens.
But it'd be great if you could have access to give out releases a little bit more often than what is currently being done.

Still, it's a great script for the most part, and it works rather well in general.
 

xShteff

Well-Known Member
So, is there any chance you could be given the rights/option to actually release the work you're doing?
I'm in no way meaning any disrespect to Petee, people move in - it happens.
But it'd be great if you could have access to give out releases a little bit more often than what is currently being done.

Still, it's a great script for the most part, and it works rather well in general.
I tried to convince him on letting someone else update it, no success so far :p
 

dissembler

Well-Known Member
looking at their traffic data.... 650k visits from may 2017 and hovering along that numbers per month ...shows alot use it still! I wish it was partly handed over to allow xshteff or tom add the little bits we badly need as they come out.
 

Pnevma

Well-Known Member
I'm actually not that fond of regular updates :D

Each time the script is updated, I have to edit it to fix the Gold/Silver job reset time...


J/K, the updates are great

looking at their traffic data.... 650k visits from may 2017 and hovering along that numbers per month ...shows alot use it still! I wish it was partly handed over to allow xshteff or tom add the little bits we badly need as they come out.
I wonder if those consider each time the script connects to the website for info update
 

Wondertje

Well-Known Member
So, brand new character on brand new game account, with brand new TW-DB account. For some reason, a quarter of the quests are marked as completed, including all four of the character class quests.

Did I do something wrong? I'm also on a new computer so cookies shouldn't be an issue. Please help :(
 

Pnevma

Well-Known Member
Did you try running the importer (just opening the TW-DB window in-game, by clicking the compass button on the right)?
 

Wondertje

Well-Known Member
Have you selected the correct character at the top right of the page?
Yes, on the brand new account I only imported the brand new character from the brand new account. Trying to eliminate as much collision as possible. After some further testing I noticed that once I start the quests on my character it's once again marked as undone, and I can proceed to track it as normal. However, some of the quests I can't do this with since I'm not able to do them, all character quests for instance.
 

Seekhunt

Well-Known Member
Hey all.

I have the exact same problem. I am from the danish TW and has just reinstalled my pc, because of other stuff. So as much of a clean setup as possible.
And i am using greasemonkey and have the exact same thing.
Almost all quest done, yet, my clothes and skills are as my game profile shows.

So it is only the quest that is somehow bugged !
So you are not alone Wondertje ;-)
 

Snr Sarg

Well-Known Member
I know there is limited support for this site these days, but wondering if anyone can help with a little problem I have with my home desktop that I occasionally use to play the game.

On this sole PC, using Google Chrome, I am unable to use the in-game calc, I get the message "tw-db.info: Please log-in first" despite already being logged in to tw-db. The sire and calc works absolutely fine on Google Chrome on my laptop...

Anyone got any ideas how I can solve this please, I have tried ths simple stuff like clearing the cache, turning off and on again etc? Cheers
 
On this sole PC, using Google Chrome, I am unable to use the in-game calc, I get the message "tw-db.info: Please log-in first" despite already being logged in to tw-db. The sire and calc works absolutely fine on Google Chrome on my laptop...

Anyone got any ideas how I can solve this please, I have tried ths simple stuff like clearing the cache, turning off and on again etc? Cheers
Tw-db will only allow you to be logged into 1 instance of tw-db.info at one time. If you log in on the pc, it will log you out of the instance on the laptop. I don't think that's the issue, but it's something to keep in mind.

For the settings, try changing the setting for 'block 3rd party cookies'. Site Settings > Cookies > Block third-party cookies to off. Another method to try, especially if you don't want to turn that setting off, is to put both sites in the Cookies 'Allow' section.

RJ
 

Snr Sarg

Well-Known Member
Tw-db will only allow you to be logged into 1 instance of tw-db.info at one time. If you log in on the pc, it will log you out of the instance on the laptop. I don't think that's the issue, but it's something to keep in mind.

For the settings, try changing the setting for 'block 3rd party cookies'. Site Settings > Cookies > Block third-party cookies to off. Another method to try, especially if you don't want to turn that setting off, is to put both sites in the Cookies 'Allow' section.

RJ
The latter did not work, moving the-west, beta.the-west and tw-db to allow cookies did not fix it.

The former, unblocking 3rd party cookies, did resolve the issue.

So, many thanks for resolving this for me, though I'm not so sure I want to leave cookies like that, hey ho
 
So, many thanks for resolving this for me, though I'm not so sure I want to leave cookies like that, hey ho
Happy to help. The cookie issue is why I run 1 browser for the-west (and associated sites) and another browser with cookie blocking enabled. Since you use Chrome, you can also set up another user of your Chrome browser with different settings.