Website TW-DB.info - English support

TJHoenecke

Well-Known Member
wtf

Okay, so now that XP support is over, I'm back to running on my main boot, which is Vista 64. FF was running the latest version of clothcalc and the database importer just fine yesterday on my XP boot, but I had never bothered to install them on my Vista boot. Now I've downloaded and installed Grease Monkey for FF, but all I get is "unresponsive script" error messages when I try to load the game -- TW eventually loads, it just still won't let me use clothcalc or the importer, the buttons don't even show up, it just says "tw-db.info: an error occurred" in the messagebar on the left. I know it's been a couple years, but I seriously don't remember having this much trouble getting this to work when I was running it under XP! On the other hand, the instructions on TW-DB do seem awfully confusing.
 

abbyghail

I don't want to be mean but you know that vista is the worst OS ever, right?
 

Petee

Well-Known Member
Please try to completely remove all possible installations of ClothCalc in your browser and install the most recent version from our site. If you know how, you should also clear the local storage of The West before the installation.
 

TJHoenecke

Well-Known Member
By "clearing local storage," do you just mean using the FF "delete recent history" command? And by "install most recent version," do you just mean click the "download" button on the "userscript" page?
 

Petee

Well-Known Member
I'm not sure if Firefox will delete Local storage using that option. It's not really an easy task to do for a non-tech user, but hopefully it can be done via this little Javascript code: (how to run?)
Code:
javascript: localStorage.clear(); void(0)
After running it, you should also reload The West. Note this will delete custom jobs defined in ClothCalc, your ClothCalc user preferences and also some other statistical data.

As for installing our script, yes, that's the way.
 
Last edited:

TJHoenecke

Well-Known Member
Same thing, same errors; the tw-db error log says "local storage is null" about five thousand times, but that's it. I can cut and paste the other command in the java console, and that seems to work, but I still can't get the import buttons to turn up or stop the error messages if I refresh the page. So, still no clothcalc, and none of the other convenience features that it adds to the game. :(
 
Last edited:

DeletedUser8131

I once had the same problem. BTW, I'm still stuck with Vista OS, also. And I'm using Chrome. I finally figured out that my TamperMonkey extension was corrupt. In this order: I deleted TamperMonkey from browser extensions, deleted all instances of ClothCalc, reloaded TamperMonkey to browser extensions, THEN downloaded Clothcalc from TW-DB site and added it to browser extensions. Maybe this will work for you.
 

TJHoenecke

Well-Known Member
ARGH, more bad news. So now, as much as I hate Screwgle, I have to switch to their crappy browser, which also appears to be the one which gives ClothCalc the most fits. I think my patience with this game is finally worn thin.
 

futurama1001

Well-Known Member
ARGH, more bad news. So now, as much as I hate Screwgle, I have to switch to their crappy browser, which also appears to be the one which gives ClothCalc the most fits. I think my patience with this game is finally worn thin.
Your patience with the game is worn thin because a third party script has problems on Windows XP and Vista, one of which is outdated and the other is sub-par, and you have to switch to what is widely regarded as the best web browser there is in order to keep using it?
 

Gandalf Greyhame

Well-Known Member
You need to slow down on the posts, futu.. I can only rep so often..
Firefox with greasemonkey can run clothcalc just fine, and it works as well as chrome for browsing the internet.
 

TJHoenecke

Well-Known Member
Just Sayin'

Your patience with the game is worn thin because a third party script has problems on Windows XP and Vista, one of which is outdated and the other is sub-par, and you have to switch to what is widely regarded as the best web browser there is in order to keep using it?
A) Are you familiar with the concept of "the straw that broke the camel's back"?

B) ClothCalc was working just fine with Firefox on XP, suddenly not so well with it on Vista, so, yeah, that's annoying.

C) My experience with Screwgle has been very subpar indeed, and so has my experince with Chrome on XP. Maybe it will be better on Vista, maybe not any better until I get to 7 or 8.

D) Go the TWDB site and look at all of the extra instructions/warnings/caveats involved with trying to use ClothCalc on Chrome. Looks an awful lot like the definition of PITA to me.

:hmf:
 

Duncol

I'm on FF/Vista too, and Clothcalc works fine.

Have you problems with other scripts like TW Collections too or just on Clothcalc ?

Have you try to uninstall/resinstall GreaseMonkey ?
 

TJHoenecke

Well-Known Member
Not using any other scripts, just want to use ClothCalc and the TWDB import features, etc. Will try uninstalling/reinstalling Greasemonkey.
 

futurama1001

Well-Known Member
D) Go the TWDB site and look at all of the extra instructions/warnings/caveats involved with trying to use ClothCalc on Chrome. Looks an awful lot like the definition of PITA to me.
It's a little bit of a pain, but it's not as bad as the amount of writing suggests. The only time you have to experience any inconvenience is when you have to update the script, and even then it takes about 15 seconds to open your Extensions, delete your current Clothcalc version and drag the new one from the downloads bar at the bottom of the screen.

Chrome is just my preference, but I have also used Firefox extensively. Like others have said, I can't imagine that it wouldn't support Clothcalc on Vista, hopefully you'll be able to get it working with a couple of tweaks.

The main point of my post was that it's silly to blame the game for browser/OS issues.
 

TJHoenecke

Well-Known Member
The main point of my post was that it's silly to blame the game for browser/OS issues.
Which has nothing to do with my original post (refer back to previous point A). I only said that the browser/OS issue might be the sort of thing to convince me to quit, given everything else wrong with the game already. I never blamed the game for the browser/OS issue.
 

Petee

Well-Known Member
TJHoenecke, please add me on skype (petee_d) if you can, I will gladly try to help you a bit more interactively. :)

ClothCalc should be absolutely OS-independent, so I believe it's not a problem with XP/Vista/Whatever. We will surely find out what's the real issue here.
 

Gandalf Greyhame

Well-Known Member
One of us!


Jokes aside, there's a better route( in my opinion, of course.) This way, you only have to do this once to install addons.
Right click your chrome shortcut, select properties. Add this to the end of the "target" box : " --enable-easy-off-store-extension-install" without quotes.
http://prntscr.com/39thj0

Then you can just install addons instantly.
 

Petee

Well-Known Member
In my case, TamperMonkey proved to be a great working solution, but yes, that is also a way to make installing UserScripts less painful. Also, if you don't like Chrome, you might still like Chromium, which provides most of the good features and unless something has changed, doesn't provide most of those bad ones, like that UserScript installation prevention thingy.