Website TW-DB.info - English support

DeletedUser39190

i got the same deal on fairbanks, but at the site, the calculator doesn't work either, just says json error.
This is a server side problem. I got the console log:

Selection_077.jpg

Edit: The game script it's working rigth now. Not working at the site.
 
Last edited by a moderator:

xShteff

Well-Known Member
Clothcalc's server side, for some reason, really does not enjoy the Patriot's weapons, Pearl weapons or the three American Army weapons. You can "patch" it by, around line 7850 (if editing in Greasemonkey), changing:

Code:
f += '<input style="display:none" type="text" name="items" value=\'' + JSON.stringify(t).replace(/'/g, "\\'") + "' />";
into
Code:
var itemsJson = JSON.stringify(t).replace(/'/g, "\\'");
var naughtyItemIds = [51530000,51531000,51532000,51539000,51540000,51541000,51550000,51551000,51552000];
for(var j = 0; j < naughtyItemIds.length; j++) {
    itemsJson = itemsJson.replace(',"' + naughtyItemIds[j] + '"', '');
}
f += '<input style="display:none" type="text" name="items" value=\'' + itemsJson + "' />";
Mind you, this does mean the script no longer takes these 9 items into consideration.

I'm really wondering what's happening on the server side though. What spell did Innogames put on these items that make poor Clothcalc go haywire?
I believe this should be fixed now. Try again?
 

Harsha..

Well-Known Member
Thanks for updating them. I was thinking - does TWDB need extra help in the form of volunteers to upload the items in the future?
 

DeletedUser35277

tw-db.info still does not recognize my log in. This has been going on for weeks now. Unable to use the calc in game at all.
 

DeletedUser39417

Does anyone know of a similar script that helps calculate things like items you can discard/are obsolete compared to other gear, best Speed gear and, best Dueling gear? TW-Calc does none of these things to my knowledge.
 

Snr Sarg

Well-Known Member
I wonder if anyone can help me with a strange issue please?

I've always played on two separate devices, a desktop and a laptop. I've always had to re-login in tw-db whenever I switch devices.

However, since yesterday, each time I try to update the red X to a green TICK in game on my laptop, I get the 'please login first' message, despite being logged in already.

I tried on my desktop earlier, which was working fine, so I guess I can narrow down the issue to one with my laptop, but anyone know where to start looking please?

NB Also having the same issue with twcalc, says I am logged out in game when I am definitely logged in on the site/

Thanks in advance

EDIT: I've just tried clearing cache in Chrome, and made it worse, tw-db cloth calc won't load at all now :(
 
Last edited:

Snr Sarg

Well-Known Member
Is the system date/time on laptop correct?
Did you try with another browser?
System date/time is correct and set to auto update

It's working perfectly in Firefox, definitely an issue with Chrome, but note I did not change any settings, this just started happening overnight

I'd say I should change browser allegiance, except it works fine on Chrome on my desktop

***shrugs***