New repeatable day of the dead

William Todd

Well-Known Member
In-game name: william todd
Affected worlds: Alamogordo and Dakota, so far
Browser: chrome
Type of Bug: repeatable holiday quest day of the dead

Description:
the quest list is 7 tomatoes, cloth, berries and puma skin but shining shoes is supposed to be the next quest but it stops with fool's gold/aztec jewelry no more quest are available

I have already hard refreshed my browser. yes
I have already consulted the Bugs FAQ. yes
I have searched if the bug has been reported before. yes
If applicable, I have tried disabling all browsers addons, userscripts and extensions. yes
 

Tom Robert

Well-Known Member
On German worlds the support has to activate the quest manually.
But forget the quest line, you won't even get a skill point at the end.
 

Apelatia

Moderator
Update:

There is currently a bug in the repeatable version of this quest-line which prevents players from accessing the "Showtime!" quest. Should you reach this stage and find yourself without the quest from Maya, please submit a support ticket and we will add the quest to your character manually.
 

Disappoint

Well-Known Member
Since we can only specify one world in a support ticket, do we need to make the same request in each world, or will one request cover them all?
 

Disappoint

Well-Known Member
Apparently the answer is yes - I submitted my request via AZ and the quest was only added in AZ.
 

Bad Billy Jack

Well-Known Member
Weird, the repeatable worked fine for me. Just finished the last step 5 hours silver mining. Not sure what to do with a 2nd useless beer though. ;)
 

Gli Sugarsand

New Member
Arizona has been really, really buggy throughout the entire Halloween / Day of the Dead event.

First, about 3 weeks ago, all of the saloon-related event quests just plain vanished - from the tracker and and from the saloon - not just Maya's but everyone of them.

The only quest giver left was the Mexican. After completing his entire series, up to finalizing the giving of 200 flowers to friends, the quest vanished. All that time and expense down the drain. This happened about a week or so ago.

The Old Woman in the Forest never did offer a quest; yet I got some of the items she asks for - like the crystal ball.

Now this morning, when I clicked on my pot of 2500 flowers, I did NOT get them. Instead, I got a message saying that it was all used up and I discard it!

I truly hate to complain but dang! Am I the only one who has run into this stunning debacle?
 

Apelatia

Moderator
Regarding the large flower pot issue, please send in a ticket if you were affected by the disappearance of the item upon it being clicked. We can reimburse you with the missing 2500 Cempasúchil flowers.