Investigating Problems since updating Google Chrome

Snr Sarg

Well-Known Member
I updated Google Chrome yesterday to Version 50.0.2661.87 m

Since then, The West doesn't want to load - if I click the 'hide' button on loading, the game will launch, but then freezes again if the map needs to be refreshed, when trying to find job locations for example.

Have tried turning off any scripts, no difference.

Tried it in Firefox and running perfectly still
 

Mustang Kate

Well-Known Member
Yep, I lost the West and Elvenar after a Chrome update, had to switch to Firefox.
All Inno games run perfectly now.
 

Snr Sarg

Well-Known Member
Firefox works, but only if you shut it down and relaunch it every hour or so because of all the memory leak, that's why I switched to Chrome in the first place, FF is way too resource greedy
 

DeletedUser35120

No problems here whatsoever. Actually it loaded faster after the update and everything's running more smooth :huh:
 

William Todd

Well-Known Member
i have google chrome and my problem after trial and error seems to be it hangs on the loading screen and i need to refresh to finish loading
 

Niklas81

Well-Known Member
hi i get to loading page but just load to 70-92 % i have chorome i have refesh the game few times

can any help it work yesttoday the 23 th
 

Magnadine

Well-Known Member
Having similar problems with Chrome as well after it was updated to version 50.0.2661.87 m (64-bit). When the loading screens freezes I keep refreshing it until it fully loads. Usually it takes several refreshes for it to load.