Kate's Ring (How do I get it?)

Alekta

You are right!!! I have the thief quest under the completed quests, but this is so weird?! I don't remember completing that quest (which is ok, because I do many quests and it's impossible to remember every one of them), but what is strange is that I can't recall to ever give away my weapon to defeat the thief and have 200$ on me.
All is solved for me now, I already completed other 3 quests and just figured that I completed the thief one too, so I don't need to wait for it anymore.
Thanks everyone that helped me figure this out!

Syntax I hope you will figure it out too.
 

Syntax

If you go back 2 pages, I already suggested that may be the case, but if you're still not sure you obviously didn't read my post. You can check where you are up to by looking at the quests completed. Go into the saloon, click on the Sheriff and scroll down to the completed quests to see if Kate's wedding band (the thief) is listed there. If it is, then yes, you have already defeated the thief, and you can click on it and read the epilogue to see that you now need to mine 5 bars of silver. There is no reason to be uncertain of what to do next or where you are up to in any quest sequence when the information is all there for you in the saloon.
Sorry, I had read the thread but a while ago before I tried out various things.

The confusion stems from the fact I've still got "Kate's wedding band (The unknown thief)" in Open Quests which has the same dialogue saying "Act like the thief etc" which is what I was trying to trigger.

However, I do have "Kate's wedding band (The thief)" in Completed Quests which says:
"Sheriff John Fitzburn: Very good. You are unarmed, it is after 7 pm and you have some money in your pockets. In 20 minutes I'll look after you."
And epilogue:
"Sheriff John Fitzburn: It was a woman. I was desperately looking for a man. She didn't have the ring anymore though." (no mention of silver mining next)
So I figured that was dealt with.

Only the conditions for "Kate's wedding band (Silver mining)" mentions needing silver, but not that that needs to be done first.

Maybe the conditions for "Kate's wedding band (The unknown thief)" should mention first doing the Silver mining quest as opposed to still asking you to imitate the thief. Either that or call them something totally different (The unknown thief) and (The thief) sound like the same quest TBH.

Anyways, I'm glad it's all resolved and thanks everyone for your advice.
 

FederigoPacitti

Does getting knocked out affect your ability to get the dealer quest on Wednesday? I am unarmed, 5+ silver, and not sleeping but it is not showing up. I did get knocked out (thx pi-man) earlier while doing some work and minding my own business. I might have to wait another week to complete this one...
 

Elmyr

Does getting knocked out affect your ability to get the dealer quest on Wednesday?
It shouldn't affect anything besides dueling other players. I'm pretty sure I did one of the Kate's duels when I was KO'ed once because I vaguely remember saying to myself that I didn't have to worry about banking the cash right away for once. I could be wrong though.
 

FederigoPacitti

Buggers - time is running out and I am not getting the dealer. I have been unarmed, left town, came back. re-armed, unarmed again. clicked on mortician. nothing seems to trigger the quest. I have 6 gold and $300 in pocket. I got knocked out by pi-man at 6:43 this morning (server time) so no one should be able to hit me. I'd do a jig in the streets but that feature has not been enabled yet.
 

FederigoPacitti

Got silver, no weapons

NOPE! I have 6 bars, stock-o-five and a spare just in case. I am down to $260 in pocket. No weapon in either hand. I do have a horse. I am currently building the residences for 30 minutes - waste of money with my building skills - just trying to stay in town.

30 minutes is up and now I am going after that dang grizzley over by Peterson's claim. (roleplaying)
 

Elmyr

AHA, there's the problem! You're an RP'er! Sorry, j/k.

I really don't understand why it's suddenly giving so many people problems. I've done the quest seven times and never had any problem. All I've got left is Settings > Support > "Bugs". Explain everything you've done, or they'll probably reply with all the same questions everyone else has been asking. There's only three more hours left on Wednesday though. :(
 

FederigoPacitti

I must be attracting too much attention with that 6th bar of silver and its scaring off the dealer! I won't sweat it this week. If it still doesn't show up when I go back in town in 13 minutes, then I'll see what happens next week. (I ASSuME you have to be in town since it is not working out here by the grizzly bear.)
Next week I'll start shootin' up the place if it still doesn't work. Well, I'll whip it into shape, anyway, since I ain't got no gun.

NOPE - still no workie today.
 
Last edited by a moderator:

deadleg

Well-Known Member
well iv sent a ticket to support after spending so much time reading what to do still no joy :mad::sad::mad::sad::mad::sad::p
 

tralfamadorian

weird... I had no money on me (plenty in the bank), and my whip on my person - and at 19:13 or so, I dropped the whip and the thief quest appeared and I beat him.

maybe it's not so complicated after all?
 

manolios

kate

i had om me 204$ and my whip equiped when the quest appeared and i accepted it...then i just went to my town and clicked on the saloon so i could do what the quest was asking...nothing...then i unequiped the whip and just left the town for a job(building coffins to make money so i could reach 300$)..when i started the job and player left the town i looked on the quests and it was asking me to duel the thief...that's all!!!so the key in my opinion is to have no weapons on you at all!!!and more than 200$.time was 10:16 PM by the way!!good luck!!!:):)
 

mobilic

Server time 23:17 (on 25/11/09). Had no weapon and $129 in my pocket. WEnt into the saloon and accepted the quest. Immediately a button apeared saying challenge thief so I clicked and had a duel with a blond chick. I won and received my revards....as simple as that. Did not lose any of the money I had, just gained the revard. Good luck
 

Arnthon

I won the duel yesterday ,,, but no reward ... very strange .... I did not get it ...
 

Boudine

Okay, I have done everything according to the walkthrough and STILL nothing happens...no new quest from the sherrif....now what?
 

superdork807

well. this is fairly upsetting. and kinda embarassing. i've spent about two weeks trying to figure this quest out then i realized. thanks to me being on the opposite side of the world, i've been trying to do it at 7 AM server time instead of 1900 PM server time. /facepalm -.-"
 

Smokingjack

Completed the 1st part of the quest 45 minutes back on the 1st attempt
Weird thing's....I only had 20$ in hand as opposed to the required 200 or 300 $ as stated in various walkthroughs:cool:

Now,have to endure a 4 day period in order to finish the quest lol
 

fentom

Lots of people has been saying not to meet the requirements and the quest appears, maybe they changed the requirements in the 1.25 Update?