Kate's Ring (How do I get it?)

Discussion in 'Questions & Guides' started by Stranger, Jan 4, 2009.

Share This Page

  1. Elmyr

    Elmyr Guest

    I wouldn't think so, but maybe it does. The Quests button used to link directly to: javascript:AjaxWindow.show('building_quest',{town_id:####},'####'); IIRC.
     
  2. Alekta

    Alekta Guest

    Well I always click the saloon on the left where it says Quests, never in the town and I have no quest anywhere.


    Hm doesn't cancelling the quest mean that you can't accept and complete it anymore? I always thought this is what it meant, but never tried it.


    I have written a support ticket and asked what's up with that quest. They said to me something that you need to look for the thief on the map. :unsure:
    Since today is Wednesday, I already completed all other 3 quests (I don't want to wait another week to complete them), and now I'm not sure if the thief one will appear to me at all since I completed all the others already :S Anyone has any idea about this?
     
  3. Elmyr

    Elmyr Guest

    No, you can always accept it again, as long as you still meet the requirements.
     
  4. Alekta

    Alekta Guest

    I see, thanks for the info then. Nice to know something new again.
     
  5. Syntax

    Syntax Guest

    This time I tried cancelling the quest and re-accepting it, going to town with 296 in my pocket (as opposed to getting there early and selling stuff).

    Still nothing.

    If anyone's reading this who's managed to complete the quest since the fort update could let us know, that would eliminate a possible bug creeping in during that update.

    Cheers
     
  6. schizowicked

    schizowicked Guest

    Are you people sure about that? Everything worked fine. I just started and finished the quest right now, only took me 3 mins to complete the whole quest, as I had 5 silver on hand already.
     
  7. schizowicked

    schizowicked Guest

    Make sure you're not sleeping in a hotel, unequip your weapon, and bring more than $200 with you.
     
  8. Syntax

    Syntax Guest

    Cheers for letting us know it actually works but no luck so far.

    Which world are you in? I'm in 2
     
  9. Syntax

    Syntax Guest

    Done that several times.

    Out of interest, did you disarm in town? I've always disarmed on my way home. Can't see why that would make a difference though :huh:
     
  10. schizowicked

    schizowicked Guest

    I've finished this in w3 and w7 before. Just completed it in w8 today, click on Saloon when you're already in town. Accept and defeat Thief, then also defeat Dealer. EDIT: Disarm in town.
     
  11. Syntax

    Syntax Guest

    Cheers... I guess that's all that's left to try.
     
  12. Alekta

    Alekta Guest

    Same here. Have been disarmed and in town since yesterday 18.50 but no quest. Of course I've been sleeping that I don't get attacked, but I've tried cancelling the sleep and going to saloon and nothing happened.

    In the meantime (from yesterday to today) I've completed the other 3 quests that are in connectiong with this one. Is there anyone that has done that too and successfully got and completed the thief quest afterwards? I'm beginning to think that I've made a mistake with completing other quests before this one. I've asked the support team about that, but still waiting for an answer so I'm just wondering if anyone has any experiences with that.

    EDIT: forgot to mention, I'm trying this on W2.
     
    Last edited by a moderator: Aug 5, 2009
  13. Syntax

    Syntax Guest

    Let's hope support find a bug in W2 which might explain this. Please let me know when you hear from back from them.

    Cheers!
     
  14. Alekta

    Alekta Guest

    Well I can show you what I got back from them so far. I must admit that I'm kinda confused when comparing both of the answers.

    Here's the first one:
    "Did you go and defeat the thief? You cannot wait for him, you must go to him on the map."

    And then I said I couldn't find him on the map and asked if he was marked with a round symbol, like the quest giver. And I got back this answer:
    "This is step for step how to obtain and complete this quest:

    1) For the first part of the quest you have to be doing nothing at 19H00 server time and have a minimum of $200 on you with no weapon equipped.

    After 19H00 - click on the Aaloon and look for a new quest from the Sheriff.

    2) You have to defeat the Thief in a duel with NO weapon. He is very easy and does very little damage, so you can try many times until you complete it if needed.

    You'll receive $1200 and 600 XP for completing that part of the quest.

    3) Next you'll need (5) Silver obtained from Silver Mining.

    4) After you have obtained 5 Silver, wait until Wednesday ... then remove your weapon and again check the Saloon for the "Defeat Dealer" Quest which is also pretty easy.

    Note that you must have 5 Silver until after you Defeat the Dealer, and it can be any time on Wednesday (server clock)

    5) You'll receive Kate's Ring from the Dealer and can then turn it in to finish the first quest and either receive +2 Charisma or +2 Strength - you have to choose."


    I will share with you if I get any other information on this. And would also ask anyone that has more info, to share with us too.
     
  15. pi-man

    pi-man Guest

  16. Alekta

    Alekta Guest

    Well I did everything that says there, wanted to finish step 1 yesterday but the quest didn't appear. Others however I could complete normally.:dry:
     
  17. pi-man

    pi-man Guest

    Make sure that at 1900 ST you aren't doing anything (not even sleeping), have NO weapon equipped, have AT LEAST $200 on you, and you have accepted the quest for Kate's Ring.
     
  18. Alekta

    Alekta Guest

    Have done all this, and that is why I'm so frustrated that this isn't working. I even had 300$, not just 200$, because on tw stats it says you need 300$.

    Do you think I should cancel the sleeping before 19.00 to get this working? I was sleeping before because I really don't want to be with 300$ on me, without weapon all day and not sleeping (can't get attacked if sleeping).

    I've tried everything, log in and out, get my weapon back on and off, but still nothing. :S
     
  19. Syntax

    Syntax Guest

    I think I see what's happened actually... We've both actually already defeated the thief but we can't complete the quest as we don't have the ring which we won't get without defeating the dealer... Can you remember if you've actually already defeated the thief?

    I had a feeling I had already defeated him, but that mission complete button is confusing as it doesn't clarify that I have.

    To defeat the dealer (as per support), you'll need 5 silver on you on a Wednesday and no weapon. I still can't silver mine so can't test this. Have you been in this situation?

    I'm going to go with the fact I have already beaten the unknown thief and that this is what unlocked the other subquests. I'll then complete those and amass 5 silvers, disarm and see if the dealer (not thief) turns up.

    That should give me Kate's ring which will solve the unknown thief quest.

    This is one confusing quest, but hopefully that's the issue :)

    Good luck!
     
  20. George Hurst

    George Hurst Guest

    If you go back 2 pages, I already suggested that may be the case, but if you're still not sure you obviously didn't read my post. You can check where you are up to by looking at the quests completed. Go into the saloon, click on the Sheriff and scroll down to the completed quests to see if Kate's wedding band (the thief) is listed there. If it is, then yes, you have already defeated the thief, and you can click on it and read the epilogue to see that you now need to mine 5 bars of silver. There is no reason to be uncertain of what to do next or where you are up to in any quest sequence when the information is all there for you in the saloon.